Vanilla Base Generation Expanded Mod

RimWorld BaseModsLeave a Comment

Author of the Vanilla Base Generation Expanded Mod: Kikohi

Vanilla Base Generation Expanded is a mod many have been waiting for. Probably one of the most disappoint aspects of venturing out in a caravan in RimWorld is the fact that no matter where you go and no matter what base you raid, after you’ve seen one, you’ve seen them all. Vanilla Bases tend to often resemble so called ‘20 granite door borg cube bases’.

Kikohi set out on a mission to fix that, and with the help from our testing community, we have created a huge library of assets that the base will pull out of, procedurally generating unique villages, towns and megabases every time you visit a new location.

The look of the bases and the assets use vary from faction to faction – tribal villages will have swathes of farmland around them, whilst pirate bases will be essentially bunkers with mortars and automatic defenses.

Vanilla Base Generation Expanded Mod features






Authors:

Kikohi, a programmer responsible for the mod.

Oskar Potocki, an artist responsible for the art and description

Vanilla Testing Expanded community, for helping us with prefabs

(CC BY-NC-ND 4.0)

Q: Does this mod work with Better Faction Bases, Bigger Faction Bases, Larger Faction Bases etc?
A: Yes, but every faction that derivate from the vanilla faction will use this mod generation instead.

Q: Does this mod affect any modded factions?
A: Yes, every faction that derivate from the vanilla faction definitions.

Q: Can I disable some aspect of the mod?
A: No, it comes in as a package. You’re either accepting all of it, or none of it.

Q: Do I need VE framework for it to work?
A: All the faction mods require Vanilla Expanded Framework to work. Make sure you always have the last version

Q: Is this mod making the game harder?
A: It will make attacking bases slightly more difficult, with more turrets and defenders, but also make attacking them much more fun and rewarding!

Q: Is this mod save game compatible?
A: Yes.

This mod is compatible with existing saves, it does not require you to start a new game.

Download

Version: 1.3

Alert! The Vanilla Base Generation Expanded Mod requires the Vanilla Expanded Framework in order to work.

Sending
User Review
5 (1 vote)